Start a new topic

Player not seeing HMD


I'm having a problem viewing videos on the player.  When launching the program, it fails to load in the HMD.  It opens on the desktop right away, but in the HMD it says, "Sorry, vma.exe is taking a while to load.  If this issue persists, take off your headset and check this app on your computer."  This happens both if I've loaded a video file and if I haven't.  Anyone else having this issue and/or know how to resolve it?


Siegfried,


one last thing I know I asked before but I wanted to clarify that sometimes you need to add a specific preference for an application to use the GPU, simply having it read "follow global" will not have it function as expected. Certainly on my systems I have had to add each app and that requires the Oculus and set it to use the GPU instead of the global mode. 


Hope you are able to get this working. if not then please drop us an email to get set up with a remote session.


Ceri

Siegfried, 


Could you send an email to vrcontent(at)dolby.com and we'll get you setup with a remote support session to investigate.


Thanks,


Ceri

Still working on it. I was on holiday for a few weeks and am picking up testing again.

 

Were you able to resolve the issue?


Please email vrcontent(at)dolby.com and someone will be able to connect with you one to one. We'll post the solution here but it will be easier to troubleshoot one to one.


Thanks



Jup, it is set to 48 kHz

 

Could you check that your sound preferences for the audio device (Rift Headphones for example) is set to 48khz and not defaulting to 44.1?
We tried the Video. Here is what came out:
When the Oculus is attached we get following behaviour:
Looking through the Oculus - Please wait...
When Video is loaded: vma.exe is taking while....
When trying to go into play: Texture Chain Swap error (one the Windows GUI)

With the Oculus not attached:
Player shows Video and goes into play

In the Oculus setup "unkonwn Sources" is allowed.

I also took out the ip-adress of the renderer. Changed nothing in the offset/FFOA Setting (exept when working with Pro Tools but resettet those for the tests).

 

Are you setting any offsets/FFOA in the video player preferences? Don't think this is the main issue as it wouldn't affect local playback but just getting a full picture.
Please try this Video file. https://dolby.box.com/s/42kt28t8pkwhfzncmpq2anhstvs7fw9v - Link expires May 10th Also try without the headset attached. If it works without the headset attached but not with then please ensure that External Sources are allowed in your Oculus Setup application.

The renderer works fine (even though we haven't tried headtracking yet because of the player issue). Got that running can monitor via headphones and pan around, etc. Was the Version we got a few days ago.


Nope, that is one of the issues. Standalone Playback also brings the same errors.



Are you able to get video to playback in the HMD if not connected to the Renderer and just playing locally?
Just noticed you mention the Local Renderer in your initial post. Could you clarify that you are actually using the VR Renderer or Production Suite Renderer and not the older Local Renderer? Local Renderer does not have a GUI associated with it and uses the Renderer Input and Renderer Output plugins rather than the Renderer Send/Return and the GUI Renderer.
PhysX control is set for the GTX1080, we also tried it over the internal Graphics card (GTX 1070 mobile Version). We also tried monophonic pictures, then get either the texture swap error or the "vma.exe ist taking a while...".

The Oculus itself works fine (viewing via Steam for example)

 

The player will only playback monoscopic files. Try cropping the picture to only keep either the top or the bottom. After that the failed to create texture is pointing to the player not using the GPU for playback, in GeForce control panel set your PhysX controls for the player specifically to use the GTX1080.

1 person likes this
Login to post a comment