Start a new topic

Dolby Audio Bridge Install Not Installing

Anyone know of / had issues with getting the Audio Bridge Installed ? It appears to install fine but then is not present when you restart the system.


OS - 10.13.6

Pro Tools - 2019.10


Attempted full uninstall & install multiple times. Possible System Extension blocking?


1 person has this question

This is great, Disable the KEXT Extensions has solved that, I can now see the Audio Bridge on my Input/ Output ... HOWEVER I've now got an issue where it's not seeing my Pro Tools HDX Card on the Output Settings which I'd like to use? Any Ideas!!??


Hi Tom,  Good news!   That is what you were supposed to see in the first place.   I'm not sure what happened in these instances.   I've installed on High Sierra without issue so this doesn't seem to be a  consistent issue.    


In any case, glad you got this sorted.  Thanks for your persistence and sharing the results.   I'm duty bound to say that you can always re-enable the permissions consent via the same method.  


Ben,  Are you willing to try this?   If so,  I hope this method solves your issues.    Please let me know if you experience differs from Tom's.


Best,

Adam

Cheers Dan.


Gave the spctl function a go as you suggested... 

That enabled the ability to "Allow apps downloaded from: Anywhere"

Deleted all previously installed Dolby files / folders / extensions.

Restarted Mac

Re-installed Dolby Atmos Renderer

Restart

Load Dolby Atmos Renderer

Still no AudioBridge option in audio driver drop downs.

Open Sys Prefs/Sec&Prvcy and there is now an Allow button next to the dialog "System software from developer "Dolby Laboritories, Inc." was blocked from loading."

Click on Allow.

Reopen Atmos Renderer and AudioBridge now appears as a valid Input and Output device.


Cheers Adam (and Ben for posting)... appears fixed!!!!! No thanks to you OSX High Seirra and your hoop jumps!


Tom (NZ)

The  spctl function within the MacOS Recovery environment can be used to disable the need to grant permissions to load a .kext.   This can be re-enabled later.   I have not tried this myself.   


Best,

Adam

 Running kextutil confirmed it as per...


Kext rejected due to system policy: <OSKext 0x7fbb7fd0da70 [0x7fffa5023af0]> { URL = "file:///Library/StagedExtensions/Library/Extensions/DolbyAudioBridge.kext/", ID = "com.dolby.DolbyAudioBridge" }


Now to figure how to safely get around it.


Cheers!

Tom

Cheers for that Adam (and Co).


 Definitely a system/OS issue... ran the "sudo kextload ..." terminal command and got a "system policy prevents loading" response as per...


Last login: Tue Nov 19 10:56:18 on console

Mix-Theatre-Dubber:~ dubber$ sudo kextload /Library/Extensions/DolbyAudioBridge.kext 

Password:

/Library/Extensions/DolbyAudioBridge.kext failed to load - (libkern/kext) system policy prevents loading; check the system/kernel logs for errors or try kextutil(8).

Mix-Theatre-Dubber:~ dubber$ 




The less obtrusive sudo kextload /path/to/kext.kext or kextutil may also do the trick but should likewise be treated cautiously.


Adam

Hi Ben and Tom,


After internal discussion and some research it seems that this is likely OS related rather than the installer itself or specific to hardware.  I've seen a number of other threads online on various forums about the same issue with other applications where the kernel extension approval either doesn't appear during install or appears but the 30 minutes for approval has elapsed and approval isn't possible.   There is a brute force was to do this wherein "you can turn off the security feature requiring user approval of kernel extensions"  Searching on this will bring up the way to do this.   If you choose to try this proceed cautiously as this has security implications for your Mac but it could be a step to try.   


For Mojave the Renderer also need to be given access to the Microphone in System Preferences/Security and Privacy.    


Best,

Adam

Hi Adam and Ben... don't want to hijack but to simply add, I'm seeing the exact same behaviour here as you Ben. Installer runs correctly / kext file present / but no AudioBridge apparent within Atmos Renderer app or from within PT.    I've run the same tests / fixes you've suggested Adam but thus far - no luck.  Would you like me to log another thread with system specs in it? If not, basic system spec below...


Pro Tools Ultimate 2019.10

McaPro (mid 2012)

OSX 10.13.6

2 x 3.46 GHZ 6-Core Intel Xeon

64GB RAM

ATI Radeon HD 5870 

Installer is the same as Ben: DolbyAtmosRenderer-3.3.0-519587.dmg


Cheers 


Tom


1 person likes this

Thanks Adam, Appreciated. 

FYI - We have multiple workstations and are currently experiencing this issue on two iMac systems

Hi Ben,   Thanks for the information.   Per the documentation the Atmos Production Suite was tested on the following:


MacBook Pro 15,1; Intel Core i7 2.6 GHz 16 GB macOS Mojave 

MacBook Pro 15,1; Intel Core i7 2.6 GHz 16 GB macOS High Sierra 

MacBook Pro 11,5; Intel Core i7 2.8 GHz, 16 GB RAM macOS Sierra 

Mac Pro 6,1; 6-Core Intel Xeon E5, 3.5 GHz, 32 GB RAM macOS High Sierra


I'm not sure why this is an issue with the iMac.  I will escalate this and reply as soon as I have any information.


Thanks,

Adam


1 person likes this

Confirmed completion of the steps above & still nothing. Yes I'm using Installer 


DolbyAtmosRenderer-3.3.0-5195857.dmg

Ok.  Thanks for info.  In addition to the above please try deleting the Applications/Dolby/Dolby Atmos Renderer folder and the Macintosh HD/Library/Application Support/Dolby/Dolby Atmos Renderer folder.


This will get as close to a clean slate as possible.   Thanks for going through these steps.   If this doesn't work it is helpful information in trying to get this resolved.   And also just to verify this is the version 3.3 installer correct?  

Thanks Adam, Did The above steps which didn't work. 

About This Mac


  Model Name: iMac

  Model Identifier: iMac17,1

  Processor Name: Intel Core i7

  Processor Speed: 4 GHz

  Number of Processors: 1

  Total Number of Cores: 4

  L2 Cache (per Core): 256 KB

  L3 Cache: 8 MB

  Memory: 32 GB

  Boot ROM Version: IM171.0157.B00

  SMC Version (system): 2.33f10


OS - 10.13.6



Hi Ben,


My bad.  To clarify the DolbyAudioBridge.Kext is in Macintosh HD/Library/Extensions and not Macintosh HD/System/Library/Extensions


Can you verify that it isn't present in the proper location and if it is repeat the steps above.


Thanks,

Adam

Login to post a comment