Start a new topic

7.1.4 Pro Tools panning

Hi, I'm a new mac Mastering Suite user so maybe I am missing something, but for the life of me I cannot figure out how to pan an object to only Ltf or Rtf. In either instance the object is also sent to the Ltr or Rtr respectively, at approximately 5db down. On the Dolby Atmos Music Panner 1.1 plug in I have the following settings when attempting to feed Ltf only:


X -100

Y 100

Z 100

Size 0


If I change only the Y value to -100, then the object feeds the Ltr only -- which seems logical to me, so why wouldn't Y set to 100 not feed Ltf only? The behavior is the same if I use the Pro Tools built in object panner.


This bring up another question which maybe should be a separate thread (possibly on the Avid DUC), but if 7.1.4 is the default format for Dolby Atmos HE/ Home Theater/ Music, then why is there no 7.1.4 format or panner option in Pro Tools?


Any insight would be greatly appreciated, thanks in advance!




Hi Gideon,


That should be working.   Are you seeing this issue reflected in the Renderer object display and metering or is this issue only apparent in your monitoring?


Thanks,

Adam

The object display looks as it should based on the planner settings, with a small object in the front upper left corner. The meters show levels in both Ltf and Ltr, the rear channel is approx 5 db down. Thanks.

Hi Gideon,


At present I'm not sure what the issue is.  Any chance you could take some screen grabs or how the music panner is instantiated in Pro Tools and the Renderer?   Could you also perhaps share the Pro Tools session minus the audio?


Thanks,

Adam

Hi Adam, I was able to resolve this by removing the object and panner plug in from the track and then re-initiating them. However the problem persists on other tracks in the session and it's hard to know when it's happening and when it's not. I will attach screen shots and the session file. Thanks,

ptx

The screen shot above shows the pro tools panner. When the problem is present, the Dolby panner behaves the same way.

Can you share the session?

Yes, it's attached to my last message, .ptx file.

My bad.   Turn off spatial coding emulation in the Rendering Preferences/Processing and this issue should go away.   I admit I'm surprised to see this result but Spatial Coding emulation should really only be turned on when you are getting closer to a full mix to emulate Spatial Coding as part of the encoding process.   It isn't meant to be auditioned with a single source.  I'll continue to investigate if this behavior is expected but turning off Spatial Coding emulation in the rendering should address this short-term.


Best,

Adam

I'm not able to replicate this issue with spatial coding emulation on or off using a session I've created and it persists in your session with all the other tracks deleted.   Can you try a new session with just a signal generator on a mono track and see if you are able to recreate this?


Thanks,

Adam

Ahhhh spatial encoding, that makes sense. Except that it seems to change  within a session but maybe that's part of the spatial encoding deal?


I opened the original session and recreated the original behavior, it was then resolved by turning off spatial encoding. I'll make another session from scratch later and see if I can duplicate the issue. Thanks for your help!

Hi Adam, I created a new session and so far I have not been able to duplicate the *weird* panning behavior.


Some other stuff I tried while playing with the original session:

• deleted all but one track in the session.

• deleted all but one buss/ output/ insert path in the pro tools I/O config.

• deleted all but one object in the renderer input assignments.


None of the above changed the panning behavior. The two actions that consistently *fix* the problem are:

• removing the object from the track and then reassigning it - with spatial encoding on.

• turning spatial encoding off.


While we're all here, I have two other related observations/ questions:

• Another unexpected behavior from the pro tools panner - the "center" control does not appear to do anything in the renderer. When turning down the center value from 100%, I can see the center speaker dim and then disappear in the pro tools panner GUI, but there is no change to the C channel output level in the renderer. This is the same regardless of the size setting or side setting in the panner, and with spatial encoding off.

• Is a 7.1.4 bed and input configuration setting anticipated in the near future for the renderer and pro tools?


Thanks for your help!




Hi Gideon, 


Straight from the Pro Tools manual - "Center % (Percentage)
In LCR, LCRS, 5.0, 5.1, 6.0, 6.1 7.0, 7.0 SDDS,
7.1, and 7.1 SDDS surround formats, the Center %
controls whether there is a discrete center channel
for the track or a phantom center channel."


Center Divergence will work with a 7.1 output (or less) sent to a bed in the Renderer.  Is has no effect when the track/panner is being used as an audio object.


I'm not aware of and can't comment if Avid has any plans for an expanded track/bus width in Pro Tools.  

Ok thanks for the clarification. I'm trying to wrap my head around the relationship between the renderer software and the PT I/O settings. If "use Atmos Renderer" is selected in the PT I/O buss page format settings, then isn't PT getting the bed format information from the renderer?

Yes.   That is correct.   However, if you want to use center divergence you'll need a track with the output set to a 7.1 (or less) subpath on the 7.1.2 output and bus defined from "use Atmos Renderer" with the default Renderer input configuration.


"Use Atmos Renderer " is handy especially w/multibed workflows but keep it mind that it will set all of your outputs used for objects to mono paths which gets in the way of using stereo tracks with linked panners using a set of objects.   


There are templates and .pio files for both a 7.1.2 bus and mono outputs and a 7.1.2 bus and stereo outputs that are installed with the Renderer if you install on your workstation.  Worth doing even if you are using the Mastering Suite on an external CPU.


Best,

Adam



Login to post a comment