Start a new topic

macOS Catalina is too new for the Production Suite Trial Installer

I am trying to apply for a trial to the Production Suite. After entering my iLok credentials, I am redirected to the download page for the trial version. But the trial version is 2.5.3 and the installer says my Mac running macOS Catalina is too new to install this. Does Dolby provide a more up-to-date version of the trial software? I wonder how other people are doing to start their trial.


Hi, 

Where are you trying to download the trial from? here: https://developer.dolby.com/forms/dolby-atmos-production-suite-trial/ ?


The trial version should be Version 3.4


image


I must have overlooked the button. I can see it now!

Login to post a comment