Start a new topic

Dolby Atmos Renderer 3.5 bugs

Hi All,


I have been trying the 3.5 and found two possible bugs:


1-When trying to input a value with decimals (e.g. 1.3) in the gain box for speaker calibration purposes, I'm able to do it only in the left channel, but couldn't do it in C, R, and the other channels. It just accepts entire values (1 or 2)


2-When I try to EQ a speaker, it will go just until 6 dB but I can see 12 db in the graphic EQ, is this normal? Or I'm missing something?


Thanks!


Sorry #1 is wrong. The bug is in the Delay window: When trying to input a value with decimals (e.g. 1.3) in the gain box for speaker calibration purposes, I'm able to do it only in the left channel, but couldn't do it in C, R, and the other channels. It just accepts entire values (1 or 2). 

Update: I tried several times and sometimes it will accept values with decimals and sometimes won't, it's kind of unstable. Anyone experimenting the same thing?


image

Ivan, 

definitely able to set decimal values for the channels here but confirm that the EQ adjustment only goes to 6 despite the gui showing to 12. We'll check with the dev team but fairly certain this is by design not error. 


Ceri

Thanks Ceri, I was wrong...The window I'm having trouble is actually "Delay". Please try to enter 1.x in channel C or R. Most of the time it won't change to an entire number, sometimes, it accepts decimal number

Hi Ivan,

The gain values are showing dB and decimal values are possible to enter. The delay values are shown in milliseconds and only accept integers. 

I hope this clears any confusion.

Fin

Thanks Fin! 

Actually, delay values It seems to be accepting decimals sometimes...Please check the screenshot. 

That's why I was asking, it's kind of confusing if those values will work or not. I can even click on Accept without warning about this.


image


Hi Ivan,

Good work, you have indeed found a bug! It seems that highlighting the LFE channel after  entering a decimal value in L does not auto-round L. Fortunately this is only graphical and the rounding still happens on pressing accept. I will report it to the team and get it fixed for the next release.


Many thanks for your help in finding this.


Fin

You're welcome Fin! Thanks for clarifying. 


Will let you know if I find anything else.


PS: Is there a forum for suggestions? It would be great to have the possibility to be able to change between presets for the speaker calibration, so you can change it depending on the monitoring configuration/format.

Hi Ivan, 


There is a feature request area on this forum: https://developerkb.dolby.com/support/discussions/topics/16000009240


So keep the requests coming, but yes, the ability to load speaker configs is on the road map for a future release.  


Thanks again


Fin

Thanks for your reply Fin!


Talk soon!

Login to post a comment